انجام پروژه ویپ و تلفن گویا

پاک کردن دوره ای لاگ های در میکروتیک

دوشنبه ۱۸ فروردین ۱۳۹۳


یکی از امکانات خوب میکروتیک برای سازمان ها و شرکت ها با کاربر کم یا متوسط و نیازمند حسابداری اینترنت با امکانات محدودتر نسبت به نرم افزارهای مشابه حرفه ای User Manager می باشد که بر روی میکروتیک نصب می شود و نیازمند سیستم مجزا نمی باشد.
این نرم افزار خوب و گاها بسیار کارگشا در مواردی برای میکروتیک مشکلاتی ایجاد می کند که می بایست با نوشتن اسکریپت های خاص آن موضوع مشکلات را به حداقل رساند.
در این آموزش به یکی از این مشکلات که پر شدن هارد و اشغال شدن CPU به سبب حجم بالای لاگ های User Manager است می پردازیم.
در بسیاری موارد نیروهای پشتیبان برای پاسخگویی به کاربران و پیدا کردن مشکلات اهراز هویت و … به لاگ های Authorisation & Authorisation & Accounting در User Manager نیازمند می باشند،در صورت فعال شدن این لاگ ها بعد از مدتی با زیاد شدن تعداد لاگ ها حجم هارد را تماما اشغال می کند و بار بر روی CPU را به شدت افزایش می دهد.
مراحل انجام کار :
  • ساخت اسکریپت

um-log1

مطابق عکس بالا در Winbox به System>Scripts رفته و اسکریپتی به نام Rm_UM_log با منبع زیر ایجاد کنید.

:local Flag
:set Flag [/tool user-manager log find]
:if ([:len $Flag] > 0) do={/tool user-manager log print append file log;/tool user-manager log remove [/tool user-manager log find];}

  • نوشتن زمانبندی

um-log2

مطابق عکس بالا زمانبدی را ایجاد کنید یا دستورات زیر را در ترمینال وارد کنید.
/system scheduler
 add name="Rm-U-log" on-event="Rm_UM_log" start-date=Sep/15/2010 start-time=07:30:00 interval=7d comment="" disabled=no
در قسمت on-event اسم اسکریپت ایجاد شده می بایست وارد شود.
نکته :
حتما NTP Client را فعال کنید تا ساعت و تاریخ میکروتیک بعد از Reboot تغییر نکند.
ntp-client
پاورقی :
در صورت نیاز به حذف Session ها ،تمام مراحل مطابق با آموزش ذکر شده در بالا می باشد و فقط در قسمت ساخت اسکریپت از منبع زیر استفاده کنید :
:local Flag
:set Flag [/tool user-manager session find]
:if([:len $Flag]>0) do={/tool user-manager session print; /tool user-manager session remove [/tool user-manager session find];}
The following two tabs change content below.

فرزانه تقدیسی

کارشناس ارشد هوش مصنوعی - پس از اتمام دوره Elastix & MCSE & CCNA & CCNP و اخذ مدارک بین المللی در این حوزه مشغول به کار شدم

Latest posts by فرزانه تقدیسی (see all)

برچسب ها : , , , , , , , , , , , , , , , , , , , , , , , , , , ,

  1. حسین گفت:

    سلام.
    ممنون از اطلاعات خوبتون. پاینده باشید

  2. زهرا قربانی گفت:

    با سلام و تشکر
    لطفا یک اسکریپت جهت پاک کردن حذف dhcp-server lease بگذارید

» ارسال نظرات

تصویر ثابت